JUST REDUCED!!! - 1980 Datsun 280ZX GL Coupe

1980 Datsun Z-Series GL

Make: Datsun
Model: Z-Series
Type: Coupe
Trim: GL
Year: 1980
Mileage: 80599
VIN: HS130-211234
Color: Blue
Engine: 2.8 FI
Cylinders: 6
Transmission: Manual
Drive type: RWD
Interior color: Blue
Drive side: Left-hand drive
Vehicle Title: Clear
Item location: Dexter, Missouri, United States
Extras
Power Mirrors, Air Conditioning, Cruise Control, Power Locks, Power Windows
CD Player
Enquire

Description for Datsun Z-Series 1980

1980 280ZX GL Coupe. 5-speed transmission. 80K miles. I purchased from original owner in '05. Since then, I replaced the radio & tape deck out (neither was working) for a Sony CD player/radio, added R12 (probably needs more), and changed the oil at regular intervals.

Other than the stereo, the car is as I bought it.

Runs great. Interior is in great shape. (no cracks in dash). LOW miles. GL package. Always turns heads.
SELLING AS-IS

NOTE: If you have any questions or need more pictures, please contact me before purchasing or making an offer.
I RESERVE THE RIGHT TO CANCEL THIS LISTING AS IT IS FOR SALE LOCALLY
********************************************************************************************************************************

UPDATE 6/4: I have had several questions... I will add the following information
I'm not a dealer, I'm a car guy. Would love to give this car a "10", but I have to live with myself and sleep at night, so here's the good and bad (IMHO).
The car has been sitting in my shop for the past 5 years. I keep a battery charged on it all the time, so occasionally I crank it up and let it idle for a while. Always fired right up and NEVER failed to crank.
As I said, I added R12 when I got home and it blew cold. I am CERTAIN without checking, it will need R12 again.
Since I got it, a couple of bubbble/rust spots on the car at the LOWER edge of the windshield showed up. I "popped" the bubbles and scrubbed the rust away and used Rustoleum on those to stop the rust from going further and so far it has worked. Actually turned out better than I could imagine. If you're just walking by it's hardly noticeable. Obviously, I drove it regularly so it has picked up a few rock pecks. One on the light bezel is the only one worth mentioning. I will post pictures of all 3 spots soon.
Oil leaks... Actually, the engine and rear end are damp, but not dripping (which doesn't bother me, most cars are underneath. There is a wet spot on the shop floor below the transmission, but without jacking it up and looking under it, I going to say the slave cylinder is leaking. Here's why... I have for the past couple of years, had to pump the clutch up to "get pressure". Now once it's pumped up...take off. It'll shift like a champ, but I suspect the slave is the culprit.
I am not a carshow judge, but I'd give it 7.5-8 (maybe 8.5 considering the age).
Thanks for checking "BLUE" out... Hope I didn't 'kill' a sale, just had to be honest. Give me an honest (serious) bid... who knows!
************************************************************************************************************************************UPDATE 6/6/19:
More picture requests - check them out...
Took pictures of the rust and pecks.

Just took it out for a quick run up and down the highway... RAN LIKE A TOP! Good temp, good pressure, good voltage. Camera ran out of battery, was going to show more. Cruise locked in.

Had a little vibration in the wheel between 50-55 (but who drives that slow...lol).

I have not done anything to this car aside from changing oil & filter, added r12, changed radio, added gas, washed and waxed, and "drove it like I stole it" for the past 14 years (well, except for the 5-6 it was parked in the shop).

ISSUE... The clock sometimes lights up... sometimes doesn't... It DID NOT light up today when I took it out for a drive.Also, I found a 'peck' at the right rear light that I didn't realize or don't remember... either way, it's been touched up before me and you can check out the picture of that corner!
Also, left rear interior has 'pulled away... So common on these cars. Also the clip that holds the Tire compartment is missing. I have the knob, but the clip it screws into is missing.

Added VIN #
Not sure if I still have the original radio and cassette deck... was asked - will search my shop and let you know!

Guys... I'm really trying to be as 'forth-coming" about this car as I can. I don't want to be 'ripped-off' and I don't want anyone to think they got ripped-off by me... SO ASK ME. I'll tell you what I know!!!

THANKS FOR LOOKING!
************************************************************************************************************************************
I did have the Cat cut off and a straight pipe put in it's place. Just remembered that.
**************************************************************************************************************************************UPDATE 6/7 - Found a radio and cassette deck that either came off this ZX or my 83... regardless, the buyer can have them as I have NO use for them.

Took it out for another run late yesterday... probably went 15 miles farther... No issues, ran great!
Rained all day today, so will try for tomorrow and post update.
************************************************************************************************************************************UPDATE 6/8 - Just took a spin. Car now has 80630 miles on it. I wasn't sure what the mileage was when I posted so I used 80599. I have probably put 40-50 miles on it during the past few days. Ran fine... Good temp, pressure, voltage. Stupid clock still doesn't work!
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
UPDATE: 6/14 - PRICED TO $ELL!!! Make a (SOLID) bid. You never know.